You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
49 lines
1.1 KiB
49 lines
1.1 KiB
{
|
|
inputs.utils.url = "github:numtide/flake-utils";
|
|
|
|
description = "cryptic-net provides the foundation for an autonomous community cloud infrastructure";
|
|
|
|
outputs = {
|
|
self, utils,
|
|
}: let
|
|
|
|
supportedSystems = [
|
|
"x86_64-linux"
|
|
"aarch64-linux"
|
|
"armv7l-linux" # rpi, I think?
|
|
"i686-linux"
|
|
];
|
|
|
|
mkPkg = (buildSystem: hostSystem: let
|
|
|
|
defaultAttrs = (import ./default.nix) {
|
|
inherit hostSystem buildSystem;
|
|
revision = if self ? rev then self.rev else "dirty";
|
|
releaseName = "flake";
|
|
};
|
|
|
|
in
|
|
defaultAttrs.appImage
|
|
);
|
|
|
|
#pkgsForBuildSystem = (buildSystem: builtins.foldl'
|
|
# (sysPkgs: hostSystem:
|
|
# sysPkgs // { "compiled-for-${hostSystem}" = mkPkg buildSystem hostSystem; })
|
|
# { default = mkPkg buildSystem buildSystem; }
|
|
# supportedSystems
|
|
#);
|
|
|
|
pkgsForBuildSystem = (buildSystem:
|
|
{ default = mkPkg buildSystem buildSystem; });
|
|
|
|
in {
|
|
|
|
packages = (builtins.foldl'
|
|
(pkgs: buildSystem:
|
|
pkgs // { "${buildSystem}" = pkgsForBuildSystem buildSystem; })
|
|
{}
|
|
supportedSystems
|
|
);
|
|
|
|
};
|
|
}
|
|
|