Everything I take with me from machine to machine.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
loadout/pkgs.nix

50 lines
1.4 KiB

rec {
mkPkgs = src: let
normalPkgs = (import src) {};
config = {
allowUnfree = true;
packageOverrides = pkgs: {
nixgl = let
src = builtins.fetchTarball {
name = "nixgl-unstable";
url = "https://github.com/guibou/nixGL/archive/7165ffbccbd2cf4379b6cd6d2edd1620a427e5ae.tar.gz";
sha256 = "1wc85xqnq2wb008y9acb29jbfkc242m9697g2b8j6q3yqmfhrks1";
};
nixgl = (import src) {
inherit pkgs;
enable32bits = false;
};
in nixgl.auto.nixGLDefault;
};
};
in pkgsArg: (import src) (
normalPkgs.lib.attrsets.recursiveUpdate { config = config; } pkgsArg
);
stable = mkPkgs (builtins.fetchTarball {
name = "nixpkgs-2105";
url = "https://github.com/nixos/nixpkgs/archive/7e9b0dff974c89e070da1ad85713ff3c20b0ca97.tar.gz";
sha256 = "1ckzhh24mgz6jd1xhfgx0i9mijk6xjqxwsshnvq789xsavrmsc36";
});
stable2305 = mkPkgs (builtins.fetchTarball {
name = "nixpkgs-2305";
url = "https://github.com/nixos/nixpkgs/archive/4ecab3273592f27479a583fb6d975d4aba3486fe.tar.gz";
sha256 = "sha256:10wn0l08j9lgqcw8177nh2ljrnxdrpri7bp0g7nvrsn9rkawvlbf";
});
edge = mkPkgs (builtins.fetchTarball {
name = "nixpkgs-edge";
url = "https://github.com/nixos/nixpkgs/archive/3ae06c380004ab1bb4146c986f38ed75ac3ec677.tar.gz";
sha256 = "sha256:0x4wjqa78ik21kja5lcy6421jjg7m7pzh2vz582rv646l69a94cl";
});
}