31 lines
867 B
Nix
31 lines
867 B
Nix
{
|
|
description =
|
|
"Garage, an S3-compatible distributed object store for self-hosted deployments";
|
|
|
|
# Nixpkgs unstable as of 2023-04-25, has rustc v1.68
|
|
inputs.nixpkgs.url =
|
|
"github:NixOS/nixpkgs/94517a501434a627c5d9e72ac6e7f26174b978d3";
|
|
|
|
inputs.flake-compat.url = "github:nix-community/flake-compat";
|
|
|
|
outputs = { self, nixpkgs, flake-utils, ... }:
|
|
let
|
|
gitVersion = self.lastModifiedDate;
|
|
compile = import ./nix/compile.nix;
|
|
in
|
|
flake-utils.lib.eachDefaultSystem (system:
|
|
let pkgs = nixpkgs.legacyPackages.${system};
|
|
in {
|
|
packages = {
|
|
default = (import ./default.nix {
|
|
inherit gitVersion;
|
|
buildSystem = system;
|
|
release = true;
|
|
}).build;
|
|
};
|
|
devShell = (import ./shell.nix {
|
|
buildSystem = system;
|
|
}).rust;
|
|
});
|
|
}
|