You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
isle/docs/shell.nix

20 lines
367 B

{
buildSystem ? builtins.currentSystem,
hostSystem ? buildSystem,
pkgsNix ? (import ../nix/pkgs.nix),
}: let
pkgs = pkgsNix.default {
inherit buildSystem hostSystem;
};
in
pkgs.mkShell {
name = "isle-build-docs";
buildInputs = [ pkgs.plantuml ];
shellHook = ''
set -e
plantuml -tsvg ./dev/*.plantuml
exit 0
'';
}