You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
isle/nix/garage.nix

33 lines
623 B

rec {
version = "0.8.1";
src = builtins.fetchGit {
name = "garage-v${version}";
url = "https://git.deuxfleurs.fr/Deuxfleurs/garage.git";
rev = "76230f20282e73a5a5afa33af68152acaf732cf5";
};
package = {
pkgsSrc,
buildSystem,
hostSystem,
}: let
compile = (import "${src}/nix/compile.nix") {
system = buildSystem;
target = hostSystem;
pkgsSrc = pkgsSrc;
cargo2nixOverlay = (import "${src}/nix/common.nix").cargo2nixOverlay;
release = true;
git_version = version;
};
in
compile.workspace.garage {
compileMode = "build";
};
}