isle/shell.nix

23 lines
344 B
Nix

{
buildSystem ? builtins.currentSystem,
pkgsNix ? (import ./nix/pkgs.nix),
}: let
pkgs = pkgsNix.default {
inherit buildSystem;
hostSystem = buildSystem;
};
in pkgs.mkShell {
buildInputs = [
pkgs.go
pkgs.golangci-lint
(pkgs.callPackage ./nix/gowrap.nix {})
];
shellHook = ''
true # placeholder
'';
}